Back
Maintenance

Survey Platform Maintenance 9/10

Completed 10 Sep at 11:00pm EDT.

Kingsley Portal
Completed

Maintenance completed

Posted 10 Sep at 11:00pm EDT.
Started

The Survey platform will be down for maintenance for a data center move beginning at 10am Central on 9/10. The maintenance window lasts until 10pm.

Posted 10 Sep at 11:00am EDT.